Kbase P24634: Progress Explorer does not show the Fathom replication folders for a database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  8/20/2009 |
|
Status: Verified
SYMPTOM(s):
Progress Explorer does not show the Fathom replication folders for a database
Unable to set up Fathom replication properties via Progress Explorer
FACT(s) (Environment):
Windows
All Supported Operating Systems
Fathom Replication
CAUSE:
There is a misconfiguration in the replication environment. For example, the registry keys for Fathom Replication are not available or the .properties files are interpreting line entries as variables.
FIX:
1. Check the registry information and make sure the following key is configure correctly:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\<version>\JAVA\REPLCP
D:\101c\dlc\jars\prorepl.jar;D:\101c\dlc\jars\proreplwin32.jar;
Alter "D:\101c\dlc\" with path to your Progress installation directory where the associated prorepl.jar and proreplwin32.jar can be found.
2. Check the DLC/properties/conmgr.properties file for:
- COMMENT lines starting with %%, replace these with #
- under the "[database.<dbname>]" sections, that the physical database name is listed AND that it does not contain the .db extention.
3. The *.repl.properties file must be in the same directory as the source database .db file and the same for your target database .db file. If it is not, move these files to the appropriate directory and then delete and add the source and target databases back through Explorer.
4. Check the values for the parameters specified in the repl.properties file for the affected database. They must be within the range limits for the parameters. Incorrect values can lead to the file not being read by the adminserver, and this will result in the folder not appearing under Progress/OpenEdge Explorer.