Kbase P24532: Cannot install a Service Pack because processes are in use
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  14/11/2008 |
|
Status: Verified
SYMPTOM(s):
Cannot install a Service Pack
Cannot install 9.1D01
Cannot install 9.1D02
Cannot install 9.1D03
Cannot install 9.1D05
Processes are running:
%DLC%\bin\environ.dll
%DLC%\bin\jni_util.dll
%DLC%\bin\jutil.dll
FACT(s) (Environment):
Progress 9.1D
Windows XP
Windows
CAUSE:
The .dlls listed in the error message are in use by another program and cannot be updated.
FIX:
Download an application called Process Explorer from www.sysinternals.com. Close all applications on your machine and then run Process Explorer.
What you need to do with Process Explorer is to go through the .exe processes
one by one and check the connected dlls. You do this by clicking on the .exe
in the 'Process' window, then go to 'View' and check 'View DLLS'. The
connected dlls are then displayed in the lower half of the screen.
In one case Process Explorer found that Tomcat was the problem. Another case found that the problem process was with IIS. Stopping Tomcat or the IIS Admin and running setup again removed the errors in these cases.