Consultor Eletrônico



Kbase P24380: Firewall timeout issues cause WebSpeed application to go down periodically
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   08/04/2008
Status: Verified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
WebSpeed 3.1x

SYMPTOM(s):

WebSpeed applications goes down periodically

Error reading socket, ret=10054, errno=2. (778)

** Incomplete write when writing to the server. (735)

Errors 778 and 735 displayed within WS server logs

ServerSocketsIPC <operation> IOException : <IOException_string> : <IOExceptionMsg_string> (8127)

ServerSocketsIPC read() IOException : java.net.SocketException: Connection reset by peer: JVM_recv in socket input stream read : Connection reset by peer: JVM_recv in socket input stream read (8127)

Error 8127 displayed within WS broker logs

Issue disappears when using Progress Explorer to connect to local AdminServer after the problem occurs

Webserver, Database & WebSpeed Transaction Server reside on the same machine

Firewall is installed on machine

DMZ is set up on machine

WebSpeed agents connect to the database via TCP/IP, i.e., -H -S -N parameters are used

CAUSE:

After some idle time, firewall times out. This firewall timeout causes the WebSpeed application to go down with 735 and 778 errors.

FIX:

Use shared memory to connect to the databases.

In order to make a shared memory connection;
On the database side; startup the db without the -H -S -N parameters.
On the agent side; remove the -H, -S, -N parameters and simply reference the database names. **In addition, full path to the database (along with database names) may be required if database is not located within the agent's working directory.