Consultor Eletrônico



Kbase P24087: Clients unable to connect via ODBC
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/11/2004
Status: Unverified

SYMPTOM(s):

Clients unable to connect via ODBC

Could not spawn a SQL server. (8842)

You have attempted to connect to a database with too many users connected to it. Retry the connection later, or increase -n on the server. (5291)

_mproserve PID's remain after the oidrvr sessions are terminated

promon user control shows that non-active ODBC connections left lying around

Database takes a very long time to shut down

CAUSE:

The shutdown process is waiting on the TCP/IP timeout to expire so that connections that have been END TASKED and therefore don't exist anymore in the _usrctrl table, can have their transactions backed out and Locks released in shared-memory.

FIX:

Before undertaking the following Steps, check the size of the bi file. Roll back recovery will be skipped by forcing an unconditional emergency shutdown and re-enacted after starting the database up again. If the bi file does not have room to expand, (disk space, limit of Fixed bi file size) then the appropriate actions need to be taken to address this first.

Steps:
1.) proshut <dbname> -by -F # to force emergency shutdown
2.) FULL REBOOT of server to clear out memory and reset processes. If this is NOT an option, then go to backup.
3.) pro <dbname> # to perform crash recovery and verify single user connection, then exit
4.) proserve <dbname> <startup parameters>
5.) TEST CONNECT the ODBC connection

if all of the above tests pass, advise users to log in, otherwise go to backup