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Kbase P23889: Autostart database hangs on startup with 8490 and 8486 error in admserv.log
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/12/2004
Status: Verified

FACT(s) (Environment):

Progress 9.1C

SYMPTOM(s):

Autostart database hangs on startup with 8490 and 8486 error in admserv.log.

Abnormal communication failure for config: (8490)

In crash handler for config . (8486)

Databases managed by the AdminServer.

Databases started in sequence from Progress Explorer.

Database starting later in the sequence hangs.

CAUSE:

Bug# 20011009-008

CAUSE:

On occasion some databases managed by the AdminServer would not register at the AdminServer startup. The problem was determined to be with the AdminServer not waiting long enough for the databases to start.

FIX:

Upgrade to 9.1D or apply last patch to 9.1C

To workaround the problem perform the following:

- increase RTInitializing from 4 (seconds) to 30 seconds; this is the number of seconds the AdminServer waits to get an initialization acknowledgement.

- increase RTStarting from 4 (seconds) to 30 seconds; this is the number of seconds the AdminServer wait to get a starting acknowledgement.

- increase RTShuttingDown from 0 (seconds) to 30 seconds


To increase the timeouts perform the following:

1. Stop the AdminServer

2. Add the above recommendations to a file, say "newTimings" for example, in the form:

RTInitializing=30
RTStarting=30
RTShuttingDown=30

3. Add the java property, -DConfigToolTimings=<dirPath>
ewTimings, to the AdminServer startup command. This can be done by modifying the proadsv file to include this java property or by adding the property to the "JVMARGS" environment variable.

4. Restart the AdminServer.