Consultor Eletrônico



Kbase P2370: Snap in failed to initialize after applying Patch 22 with 9.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   01/11/2003
Status: Verified

FACT(s) (Environment):

Progress 9.1C

SYMPTOM(s):

Error attempting to launch Progress Explorer

Snap in failed to initialize

CHANGE:

Applied patch 9.1C22 or later

CAUSE:

Prox.dll and proexptlr.dll have not been registered after patch application.

FIX:

In the README.PAT file that comes with the patch, step 4 in the INSTALLTION NOTES section informs the user to register the "proexptlr.dll" file that comes with this patch.

Step 4 from the README.PAT file reads as follows:

4. Restart the PROGRESS processes and verify that this patch has fixed any issues as expected.

Make sure you register your new "prox.dll" file. From the "Start" button, select "Run...". Enter the following command:

[PROGRESS]\bin\regsvr32.exe [PROGRESS]\bin\prox.dll

and click on the "OK" button.


For correct operation of Progress Explorer make sure you register your new "proexptlr.dll" file.

From the "Start" button, select "Run...".

Enter the following command:
[PROGRESS]\bin\regsvr32.exe [PROGRESS]\bin\proexptlr.dll

and click on the "OK" button.


NOTE: You will also be required to add your local or remote server again in Progress Explorer. Your configuration should stay intact (Databases, AppServer, etc.).