Consultor Eletrônico



Kbase P23455: Progress Explorer can no longer connect to the OS server after a reboot (8336)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   2/7/2009
Status: Verified

SYMPTOM(s):

Connect to Progress Explorer fails after reboot of server

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

Starting AdminService with the local administrators account.

Message (excp): UI Updates in wrong thread: .TCP Accept-1

Stack Trace: java.lang.Exception: UI Updates in wrong thread: .TCP Accept-1

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
Progress 9.1x

CAUSE:

Problem with the account used to start the AdminService.

FIX:

Two possible methods to resolve this problem:

1. Change the AdminServer to start as the system account

,or

2. Reinstall the adminserver:
a. Stop all databases.
b. Remove the auto start for all databases in (conmgr.properties file) and all brokers in (ubroker.properties file)
c. Stop AdminService.
d. Run admsrvc.exe /remove from the %DLC%\bin directory.
e. Reboot the server.
f. Run admsrvc.exe /install from the %DLC%\bin directory.
g. Bring up progress explorer and add the localhost.
h. Connect to localhost.
i. Reset all features back to automatic.