Kbase P23259: Errors 5 and 1058 when Starting ProControl
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  20/04/2005 |
|
Status: Verified
FACT(s) (Environment):
Progress 8.3x
Progress 9.x
SYMPTOM(s):
Error 5: Access is denied starting ProControl
Error 1058 Communicating with ProService
Error 5: Access is denied
Using administrator account with both local and domain administration rights
Connecting as Admin User LOCALLY
HKLM/PSC/ProService registry keys appear correct
Only one copy of %dlc%\bin\proctrl.cpl exists
Control Panel -> SERVICES -> ProControl returns error 5: Access is denied
CAUSE:
"Error 1058 Communicating with ProService" quotes 1058 ERROR_SERVICE_DISABLED - which referrs to the ProControl service being disabled and the permissions on DLC folder, which in this case did not have a SYSTEM account which is needed, is returning "Error 5: Access is denied" message.
FIX:
First enable the ProControl Service:
Control Panel -> ProControl -> Properties -> Log On -> Hardware Profile set to ENABLED.
Then add a SYSTEM account to access the DLC Progress installation folder with FULL rights and ensure that these are inherited by child folders.