Kbase P22939: Progress proshell.dll and evntlog.dll files are in use when installing Progress 9.1x or a 9.1x servi
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/23/2006 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1X
OpenEdge 10.0X
Windows
SYMPTOM(s):
Progress proshell.dll and evntlog.dll files are in use when installing Progress 9.1x service pack.
Progress proshell.dll and evntlog.dll files are in use when installing a Progress 9.1x product.
CAUSE:
This is a known issue where the operating shell is not releasing these .dll's.
FIX:
I. To workaround this problem, follow these 6 steps listed below:
1) Set Progress 9.1x AdminService/ProService to manual (if "Autostart" is enabled).
2) Reboot the Windows machine.
3) - DO NOT OPEN any .p, .pl, .i, .w ... after the reboot, or do not start any Windows Explorer session in a directory where .p, .w ... are located -
4) Apply the Progress 9.1x service pack (or install the new Progress product).
5) Reset the Progress 9.1x AdminService/ProService to "Autostart". (if needed)
6) Restart Progress 9.1x AdminService. (if needed)
II. Also, running setup.exe from Start>>Run will bypass the problem.