Kbase P22842: Authorization failed error when attempting to view a pre-existing Linked table in Microsoft Access.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/5/2007 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1x
MERANT 3.60 32-BIT Progress SQL-92
SYMPTOM(s):
Linked table successfully created in Microsoft Access to a Progress Database table.
Error when attempting to view Linked Table the next time the user enters the Access database.
Users are forced to delete and relink the Progress tables from within Microsoft Access
No problem viewing the Linked Table right after link is created.
Access denied (Authorization failed) (7512)
Access denied(Authorisation failed)
CAUSE:
Please note that this a Microsoft issue and not a Progress issue.
When attempting to view a pre-existing Linked Table, Microsoft Access attempts to re-connect with a different userID than the one in the DSN which was used to create the Linked Table. The userid being passed is, by default, "admin".
FIX:
Method 1:
When you (re-)create the link choose Save Password at the table selection window.
- OR -
Method 2:
Create a user called "admin" into the Progress database and make sure you enter the same password which is defined in Microsoft Access.
- OR -
Method 3:
If the Access database was already created with the default Admin account, follow these steps to address the issue:
- Open the Access database which contains the link.
- Go to Tools / Security / User and Group Accounts
- On the Users tab create a new user (same username as the Progress SQL-92 DBA account).
- Make it part of the Admins group.
- Go to the Change Logon Password tab and type in a password for the Admin user. - Go to Tools / Security / User and Group Permissions.
- Highlight the new user and table.
- Choose Administrator in the Permissions check box.
- Go to the Change Owner tab.
- For the Object type choose Table and for New Owner choose new user you created. - Choose Change Owner (you should see the change on screen).
- Repeat this for each linked table.
- Close Access and open it again.
- Make sure the user you created is displayed and choose OK (blank password).
- Now you should be able to connect to the linked database without any problems.
For more details, see MS KBase:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;254372