Consultor Eletrônico



Kbase P22753: Cannot start Progress client from icon
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/04/2009
Status: Unverified

SYMPTOM(s):

Cannot start Progress client from icon

Cannot start AppBuilder session from desktop icon

Cannot start Procedure Editor from start menu shortcut

Error posted when Progress session launched from icon

** "<file-name>" was not found. (293)

** "adecom/_ade.p" was not found. (293)

Other file names may appear in error 293 message depending on Progress / OpenEdge version

Additional error messages may appear depending on Progress / OpenEdge version

Error messages reappear when alert box is closed using the OK button.

FACT(s) (Environment):

Windows
Progress 9.x
OpenEdge 10.x

CHANGE:

Modified PROPATH in ProTools

CAUSE:

The directory added to the PROPATH was placed before %DLC%\gui, and contained files with names that conflicted with files in %DLC%\gui needed to start the Progress client.

FIX:

The following steps include instructions for editing the Windows registry. Always use care when modifying the registry; incorrectly modifying the registry can make your Windows system unusable. Be sure to back up the registry before making any changes.

Kill the Progress client from Windows Task Manager.
Close any remaining alert boxes.
Back up the Windows registry.
Using regedit, modify the PROPATH keys under HKEY_CURRENT_USER\Software\PSC\PROGRESS\<version>\Startup and HKEY_LOCAL_MACHINE\Software\PSC\PROGRESS\<version>\Startup to remove the newly added directory.
Start the Progress client. It should start correctly this time.
From the client, start ProTools.
Choose the Propath Editor.
Add the desired directory, placing it below the Progress startup directories.