Consultor Eletrônico



Kbase P21994: Getting errors 9450, 9451, 291, 6072 on temporary files when
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   26/03/2003
Status: Unverified

FACT(s) (Environment):

HP-UX 11

FACT(s) (Environment):

Progress 9.1D

SYMPTOM(s):

<function>:Insufficient disk space during <system call>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (9450)

<function>:Unknown O/S error during <system call>, errno <error number>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (9451)

Insufficient disk space or Write access denied. (291)

SYSTEM ERROR: error writing, file = <file-name>, ret = <return-value> (6072)

Errors occur on temporary files

CAUSE:

Running out of space for temp files.

The temp files for the appservers are created in the working directory for each asbroker. This is the directory specified under Progress Explorer, in Working Directory under the Properties for each broker.

The temp files for other clients are created in the working directory for that client, or under the directory specified by the -T client startup parameter.

FIX:

In these directories for temp files ensure that there is enough space for the temp files to grow, especially if there are large transactions that might be running. The error messages (9450, 9451, 291, 6072) are all indicating that you are running out of space there.

If a -T is being specified, verify that it refers to a valid directory.