Kbase P21395: Progress Explorer and WSAMAN is unable to communicate with a running WSA instance
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/21/2008 |
|
Status: Verified
SYMPTOM(s):
Progress Explorer is unable to communicate with a running WSA instance
WSAMAN is unable to communicate with a running WSA instance
Status displays "Web Service Adapter <WS Name> is Not Running"
Web Service Adapter <WS Name> is Not Running
WSA request error: CONNECT FAILURE
Connection failure with WSA at http://webserver:80/wsa/wsa1 during query request, exception: The http protocol connection failed: ConnectException: Connection refused: connect (9990) (10770)
FACT(s) (Environment):
The WSA servlet is configured correctly
The WSA servlet is up and running
OpenEdge 10.x
All Supported Operating Systems
CAUSE:
Web Services was installed with the incorrect URL for the Web Service Adapter instance.
FIX:
Edit the ubroker.properties file. Search for WSA or WSA.<Specific_Name>. Modify the wsaUrl= for the correct URL setting to the WSA instance, for example:
[WSA.wsa1]
wsaUrl=http://webserver:8080/wsa/wsa1
After this change, restart both the AdminServer and the Java Servlet Engine (e.g. Tomcat).