Consultor Eletrônico



Kbase P20740: AppServer hangs if Appserver log file grows to 2GB.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/11/2009
Status: Verified

SYMPTOM(s):

AppServer hangs if Appserver log file grows to 2GB.

FACT(s) (Environment):

UNIX
Progress 9.1x
OpenEdge 10.x

CAUSE:

Log files have a limit of 2 GB.

When AppServer log files hit the 2 GB the performance or action of the server is stopped. That is because the log file has reached the 2 GB limit.

Even when large files are enabled on the platforms where Progress supports this, the only files which are allowed to exceed 2 GB are:
After Image Extents (.an),
Before Image Extents (.bn),
Control Area Extent (.db),
Data Extents (.dn)
Transaction Log File (.tn).

When the AppServer log file hits 2 GB it is normal or expected behavior for the AppServer to stop.

FIX:

Trim or reduce the size of the log file to normal operation.

Examples:
BOURNE shell:
$ > appserver-log-file-name

C shell:
% cp /dev
ull appserver-log-file-name