Consultor Eletrônico



Kbase P19904: Intermittent 8089 and 8091 errors in WebSpeed broker log
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   05/11/2009
Status: Verified

SYMPTOM(s):

Internal server error in browser

Error <errMsg> ... disconnecting client. (8091)

Error No Servers available ... disconnecting client. (8091)

ERROR: No servers available. (8089)

Errors 8091 & 8089 are displayed in broker log

Errors are intermittent

No errors in WebSpeed server log

No errors in database log

Database is remote to WebSpeed Transaction Server

FACT(s) (Environment):

Windows 2000
WebSpeed 3.1x

CAUSE:

Errors 8089 and 8091 are caused by no availability of agents at the time of client's requests. Upon each client request, the broker will attempt to get a free agent from available agents queue in requestTimeout seconds but if the queue is empty, the broker will report errors 8089 and 8091.

Two properties will affect this behavior:

maxSrvrInstance: The maximum number of servers maintained in the server pool that this broker manages. If you do not set this property, the broker will continue to create more servers as long as they are needed up to the number licensed.

requestTimeout: Specifies the amount of time, in seconds, the broker will wait for a server to become available for processing a request. After this timeout has expired the client will receive a "no servers available" error message.

FIX:

Increase the maxSrvrInstance or/and requestTimeout values.

By default, the values are set to maxSrvrInstance=10 and requestTimeout=15

These values can be changed by editing the ubroker.properties file for your broker and/or through the Progress Explorer.

Within the Progress Explorer;
Request Timeout can be found, under the Broker section within the Properties, select Advanced Features

Maximum agents can be found, under the Agent section within the Properties, select Pool Range.