Consultor Eletrônico



Kbase P19729: Appserver error (8551) Socket Closed, when starting Appserve
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   21/08/2003
Status: Unverified

FACT(s) (Environment):

Progress 9.1D

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

An error occurred while receiving a message from the NameServer - Error: (8551)

An error occurred while receiving a message from the NameServer - Error: socket closed. (8551)

CAUSE:

The Appserver broker was not being shutdown correctly but killed, this left the port which an agent was using open. When the broker was restarted and the agent attempted to use the same port, as it was already open, this error occurred.

FIX:

Make sure that the Appserver broker is shutdown correctly, this will make sure the ports used are released correctly and able to be used again without problem.