Consultor Eletrônico



Kbase P19135: Roll forward of ai file stops with an out of sequence problem.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   08/06/2005
Status: Unverified

FACT(s) (Environment):

HP-UX 11i 64-bit
Progress 9.1D

SYMPTOM(s):

Roll forward of ai file stops with an out of sequence problem.

Running rfutil dbname -C roll forward fails with error (8019).

Expected ai file number but file specified is in sequence. (8019)

Expected ai file number 423 but file specified is 424 in sequence. (8019)

Service pack 03 has been applied to Progress on both the production database and the hot backup database.

The database was last changed <date>. (831)

** The after-image file expected <date/time>. (832)

** Those dates don't match, so you have the wrong copy of one of them. (833)

CAUSE:

bug# 20030226-012

CAUSE:

In older versions of Progress, when a transaction finished, sometimes it
needs to clean the index chain, this, in some cases, will take a long time
and stop other users' activities. To solve this problem, this clean
operation was delayed until the next user touched this index. This
means the user who caused the clean leaves without doing anything but the
subsequent users will pay the penalty. This sounds unfair, but appears to
users as an improvement in performance. RFUTIL is also a user to the
database, it has to pay the penalty sometimes (notice this index clean
operation happens randomly). But in the case of roll forward, it should
not do it because it might modify the target database and cause either
(831), (832) and (833) errors. The error can also be (1028) with the
bkupdctr the same in both the bk header and note, because CXREM modified
the database first, then RFUTIL tries to apply that note again.
The fix is to stop the RFUTIL clean of the index chain.

FIX:

Upgrade to Progress 9.1D06 or later.