Consultor Eletrônico



Kbase P18875: Cannot access a restored procopy database - error 210
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/19/2009
Status: Verified

SYMPTOM(s):

Cannot access restored procopy database

SYSTEM ERROR: Attempt to read block <number> which does not exist. (210)

SYSTEM ERROR: Attempt to read block <0> which does not exist. (210)

FACT(s) (Environment):

Backups are procopy of the runtime database
procopy of the runtime database is restored from NT backup on tape device
restore of previous procopy backup can also not be accessed
All Supported Operating Systems
Progress/OpenEdge Product Family

CAUSE:

Running the dbscan against the restored database showed an unusual but not specific result. The Scan continues without ANY errors until a certain point, and thereafter there is a sequential:

"Can't find block 153201 (4902432)
...
Can't find block 153261 (4904352)",
where block 153261 is the last block in the application data (.d) area.

This pointed to the fact that the restore of the backed up procopy had probably failed to complete properly, probably due to hardware failure or file truncation at some point in the process.

FIX:

Restore the backup again, to a different location and compare the output of the dbscan against the first.

- If the second scan shows no errors, then the database can now be accessed and the cause was definitely due to problems with the restore.
- If the scans are the same, then there is most probably an issue with the backup itself and technical support will be able to best advise on further action regarding removing bad records, although it is better to try and restore a previous backup, than to loose records
- If the scans are different, (iow: still report errors) then there is a fault with the hardware, which will need investigating before continuing. Otherwise the process can be repeated on a different machine.