Consultor Eletrônico



Kbase P18680: Cannot start after imaging on a new or restored database (6656)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/19/2009
Status: Verified

SYMPTOM(s):

Cannot start after imaging on a new or restored database

Database does not have an ai area. AI cannot be enabled. (6656)

rfutil <dbname> -C aimage begin returns error 6656

FACT(s) (Environment):

Database restored through prorest
prostrct list confirms no ai extents
ai extents are not on a NFS
All Supported Operating Systems
Progress/OpenEdge Product Family

CAUSE:

When a probkup is taken, the after image files are not included because they are not at all relevant to the backup. When restoring the probkup, unless after image (ai) file names are specified in a pre-existing database structure file (dbname.st) ai files will not be created during the restore. The database must have at least one ai extent added to it's structure before after imaging can be enabled.

FIX:

After considering your after-imaging strategy, add ai extents.

For further information please refer to the references included below.