Kbase P17804: msgopen: unable to open file promsgs when starting Proenv se
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/22/2003 |
|
Status: Unverified
SYMPTOM(s):
msgOpen: unable to open message file: PROMSGS
msgopen: unable to open file promsgs when starting Proenv session
When starting a proenv session error msgOpen: unable to open message file: promsgs
Working directory is a sub directory of the DLC directory
Installation Directory names do not contain spaces
Only one Progress Installation
Custom installation selected
showcfg only ProVision License Installed
CAUSE:
It appears that the ProVISION installation failed to initialise in the correct manner:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\9.1x\Startup
Contains only the /JAVA registry key listed. We would normally expect there to be at least /Colors; /fonts; /WinChar Colors; WinChar Startup; /Startup in addition to the /JAVA registry key.
FIX:
The Progress Working directory should not be a sub-directory or even the same directory as the DLC install directory. They should be in either different directories at the same tree level or completely separate directories.
Uninstall and re-install Progress - Administrative privileges are needed on the machine that Progress is being installed/uninstalled on
1) STOP Progress Services (AdminServer and ProControl) if needed
2) Then set these through "STARTUP"-bt -> MANUAL
3) Progress UNINSTALL
4) Re-install to a correct directory configuration for example:
DLC = D:\91D\DLC
WRK = D:\91D\WRK