Kbase P17481: AdminServer is not starting
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  25/08/2009 |
|
Status: Verified
SYMPTOM(s):
AdminServer is not starting
Error 1053: The Service did not respond to the start or control request in a timely fashion.
Tried to start more than once using Windows Services
AdminServer won't start
FACT(s) (Environment):
found java process in memory
AdminServer port is in use
Proadsv -query reports the AdminServer is not alive.
Net stat -a shows port 20931, the default AdminServer port, is in use.
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
Previous session did not finished properly. Java processes are hung
FIX:
For UNIX, Kill any jvm processes that show from a 'ps -ef || grep jvm' command. Then restart the AdminServer with proadsv -start.
For Windows, Terminate all java.exe using Windows Task Manager. Make sure that that "Show process for all users" is turned on when looking for java.exe process. Restart AdminServer.