Kbase P17397: Problems with running Progress after applying a Service Pack
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  4/26/2006 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1D
OpenEdge 10.x
SYMPTOM(s):
Cannot start database after Service Pack installation
This version of PROGRESS does not support a database server. (1733)
This version of PROGRESS does not support Spin Lock Retries (-spin). (4965)
This version of PROGRESS does not support Multiple Semaphore Sets (-semsets). (6549)
Access is denied on 'probuild'
CHANGE:
Applied Service Pack
CAUSE:
The Service Pack has been applied "old" way that patches were applied, ie the Service Pack file was extracted directly into the Progress DLC installation directory. The service pack setup installation was never run.
FIX:
From the introduction of Progress 9.1D Service Packs replaced patches. They are not meant to be installed directly on top of an existing installation. By doing this, you end up with an incomplete product set. To correct this problem, do the following:
1) Uninstall the exsiting Progress product(s) version of the Service Pack as it is corrupted because of wrong SP installation (eg: uninstall Progress 9.1D if you incorrectly applied a Service Pack for 9.1D)
2) Reinstall the Progress product(s) major release version (eg: Progress 9.1D)
3) Extract the Progress Service Pack files into a temporary directory/folder.
4) Run installation utility (from directory created at step #3) that came within service pack (UNIX: proinst; WINDOWS: setup.exe)