Consultor Eletrônico



Kbase P17034: Unable to start AdminService on Windows 2000 if Everyone Group is not assigned to NT Service
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   7/14/2009
Status: Verified

SYMPTOM(s):

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

AdminServer not starting if set to Logon as LocalSystem Account

Progress Explorer can not connect to AdminServer starting as LocalAdmin Account.

FACT(s) (Environment):

Windows 2000
Windows Domain Controller
Progress 9.x
OpenEdge 10.x

CAUSE:

When promoting a server to a DOMAIN CONTROLLER within Windows a change is made by the Windows utility to all services running on the machine which removes the Everyone Group from each Service.
The removal of the Everyone Group is what causes Progress AdminServer from starting correctly or allowing connection remotely.

FIX:

1) Open Control Panel
2) Open Administrative Tools
3) Open Domain Security Policy
4) Double click on the service to be modified
5) If the "define this policy setting" is checked then you must add the individual user which the service uses to login or the "Everyone" account
within the "Edit Security button" dialog
If the user that is chosen to login for the service is not in this list then the service can not be started.