Kbase P16885: Agents hang when going through a router using Network Address Translation
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1x
WebSpeed 3.1x
SYMPTOM(s):
Agents hang in BUSY state when request is sent
WebSpeed Broker dies
Distributed WebSpeed configuration
FrontEnd (Messenger, NameServer & Transaction Server)
BackEnd (Database)
Agents connect to database at startup
CISCO router with Network Address Translation is between Transaction Server and db.
Router's translation tables are cleared often
CAUSE:
This problem is that NAT is closing all open ports when it refreshes the translation tables. If the agent connects to a database at startup and they are active(AVAILABLE/BUSY) when the routers's translation tables are cleared, all connections will no longer work because the information used to route packets no longer matches what was in place when the connection was established. So the connection will be broken because the addressing information is no longer valid.
FIX:
Set the minSrvrInstance to zero and the autoTrimTimeout (for the agent) to a value before the router's mapped tables are cleared.
Example settings
Routers mapped tables are cleared = every 1 hour
autoTrimTimeout is set = 10 minutes
minSrvrInstance set = 0
If there is no agent activity for 10 minutes, the broker will trim the agents down to zero. If the router's mapped tables are cleared every hour, thus when a new request comes in, the new agent will be fired off and be able to locate the database.