Consultor Eletrônico



Kbase P16711: Can't connect to a Win32 database using PROMON, error (1423).
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Unverified

FACT(s) (Environment):

Windows
Progress 8.x
Progress 9.x

SYMPTOM(s):

Can't connect to a Win32 database using PROMON.

There is no server for database <>. (1423).

CAUSE:

Within the Windows command line operating environment, PROMON must be run using a fully qualified path to the database. This is necessary because Windows uses a portion of the directory name and filename within its shared memory ID. These shared memory ID's are what Progress uses to locate a database within shared memory (in order to make the PROMON self-service connection). Thus, if your PROMON command line doesn't have the complete path it may fail with the following error:

There is no server for database <dbname>. (1423)

FIX:

Two solutions:

1 Use a fully qualified path to the database.

EXAMPLE: %DLC%\bin\PROMON C:\workdir\myDB

2) Use the Progress PROENV window to run your PROMON session. This command line environment will have the Progress operating environment already defined, thus the database's path (i.e. the working directory) is already pre-defined.