Kbase P15666: JDBC connection to progress database fails using the SQL Exp
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/21/2003 |
|
Status: Unverified
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
FACT(s) (Environment):
MERANT 3.60 32-BIT Progress SQL-92
FACT(s) (Environment):
Progress 9.x
SYMPTOM(s):
JDBC connection to Database via SQL Explorer tool failed.
=== SQL Exception 1 ===
SQState=08001
ErrorCode=0
No Suitable Driver
java.lang.UnsatisfiedLinkError:
java/security/AccessController.doPrivileged Possible causes: If you
are trying to use J/Direct (@dll.import), check your compiler version
(for JVC, requires 4336 or greater.) If you are trying to use RNI,
there are new requirements: see documentation.
at java/security/AccessController.doPrivileged
at java/rmi/server/RemoteServer.<clinit>
at
com/progress/vj/explorer/ProgressExplorer.getClientEventBroker
at com/progress/vj/util/ProDialog.<clinit>
at com/progress/vj/util/ProDialog.getActiveProDlg
at com/progress/vj/util/ProMsgBox.show
at com/progress/vj/util/ProMsgBox.error
at com/progress/vj/util/ProMsgBox.error
Control Panel> Data Sources (ODBC) test connect feature fails.
Specified driver could not be loaded due to system error 1114 (MERANT 3.60 32-BIT Progress SQL92 v9.1C
Procli92.dll file was copied to C:\winnt\system32 directory.
The Hkey_Local_Machine\Software\ODBC\ODBCINST registry key contained the correct settings for the ODBC driver.
CAUSE:
Environment issue. Could not determine the environment problem.
FIX:
1. Remove previous environment variables pointing
2. Uninstall client networking.
3. Reboot machine.
4. Ensured that previous %DLC% directory was removed.
5. Removed registry keys for progress. Hkey_Local_Machine\software\PSC and Hkey_Current_User\software\PSC
6 Reboot machine.
7. Reinstall Client Networking.