Consultor Eletrônico



Kbase P15493: No AdminService created - Modify registry to work around the problem or upgrade to 10.0A
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   02/04/2008
Status: Verified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
Progress 9.1C
Progress 9.1D
Progress 9.1E

SYMPTOM(s):

AdminServer fails to start launching from AdminService

AdminService registry keys not created during the installation

"AdminService for PROGRESS 9.1x" not installed

Missing "AdminService for PROGRESS 9.1x" under services

CAUSE:

BUG# 20010629-018

CAUSE:

The code that does the tailoring of the installation for the NT services
(such as adminserver and procontrol) was incorrectly checking a specific set
of licence "right-to-run" bits. This caused the registry entries for the
adminserver to not be setup if a certain combination of products in
installed.

FIX:

Upgrade to 10.0A or use following workaround:
In order to workaround the problem, after the Progress installation finishes, click on the 'proenv' icon to launch the proenv command shell and type:

proenv> admsrvc /install
"AdminService for PROGRESS 9.1x" should appear in the Services applet.
Next step is to create missing AdminService registry keys:

<91d_admsrvc.reg>
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\9.1D]
"DLC"="E:\\91d"

[HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\9.1D\ShutdownCmd]
"Chimera"="\"E:\\91d\\bin\\jvmstart\" -o eventmgr -w @{WorkPath} @{JAVA\\JREHOME}\\bin\\java -classpath @{JAVA\\JRECP};@{JAVA\\PROGRESSCP};@{JAVA\\FATHOMCP} @{JAVA\\JVMARGS} -DInstall.Dir=@{Startup\\DLC} -DWork.Dir=@{WorkPath} -Djava.jvmargs=@{JAVA\\JVMARGS} -Djava.security.policy=@{JAVA\\JAVAPOLICY} -Dadmsrv.jvm=@{JAVA\\JREHOME}\\bin\\java com.progress.chimera.adminserver.AdminServerType -stop -service"

[HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\9.1D\StartupCmd]
"Chimera"="\"E:\\91d\\bin\\jvmstart\" -o eventmgr -w @{WorkPath} @{JAVA\\JREHOME}\\bin\\java -classpath @{JAVA\\JRECP};@{JAVA\\PROGRESSCP};@{JAVA\\FATHOMCP} @{JAVA\\JVMARGS} -DInstall.Dir=@{Startup\\DLC} -DWork.Dir=@{WorkPath} -Djava.jvmargs=@{JAVA\\JVMARGS} -Djava.security.policy=@{JAVA\\JAVAPOLICY} -Dadmsrv.jvm=@{JAVA\\JREHOME}\\bin\\java -Djvmstart.debug=0 com.progress.chimera.adminserver.AdminServerType -start -service"
<\91d_admsrvc.reg>

Copy the text between the <91d_admsrvc.reg> tags into the file called 91d_admsrvc.reg and merge it into the registry.

Make sure to replace the location for the Progress installation folder with your own (in this example the installation folder is "E:\91d").

Be careful to have only one line after each registry key, as there
might be some carriage return characters added at the wrong place, i.e.:
[HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\9.1D]
one line....

[HKEY_LOCAL_MAC...\9.1D\ShutdownCmd]
one line...

[HKEY_LOCAL_MAC...\9.1D\StartupCmd]
one line...

After adding the missing registry keys test the AdminService from the Services applet.

This installation bug has been fixed in OpenEdge 10.0A.