Consultor Eletrônico



Kbase P15252: Fathom 2.0A installation fails due to no supported versions being available to associate with.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   17/02/2011
Status: Verified

SYMPTOM(s):

Fathom installation fails with error.

Service Pack 9.1D01 installed

DLC and PROCFG are set correctly prior to installation.

Removing DLC and PROCFG does not resolve the issue.

9.1D is the only Progress install on the machine

Fathom was never installed on the machine.

Error: No supported version of Progress are available to associate with this installation

FACT(s) (Environment):

Progress 9.1D
Fathom 2.0A
Windows

CAUSE:

When installing fathom, the windows version checking is accomplished by interrogating the registry for versions available to associate. The install program looks at the HKEY_LOCAL_MACHINE\SOFTWARE\PSC\Fathom key and the
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS key. The PROGRESS key tells the
install program which versions are installed and the FATHOM key tells the
install which versions are already associated with FATHOM.

Due to the existence of the HKEY_LOCAL_MACHINE\Software\PSC\Fathom and HKEY_LOCAL_MACHINE\Software\PSC\Fathom Mgt SE keys in the registry, the installation routine believes Fathom is all ready installed and associated with the current installation.

FIX:

Export the HKEY_LOCAL_MACHINE\Software\PSC\Fathom and HKEY_LOCAL_MACHINE\Software\PSC\Fathom Mgt SE keys and remove them. Once this is done, rerun the Fathom install.