Consultor Eletrônico



Kbase P15180: Long time out with the CONNECT() method to an AppServer
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/16/2008
Status: Unverified

FACT(s) (Environment):

Windows 98

SYMPTOM(s):

Long time out with the CONNECT() method.

-H and -S parameters point to a host/port combination where no NameServer is listening.

CAUSE:

This is not a Progress issue and is specific to Windows 98.

When Progress tries to connect to an AppServer, the first step is to try and contact the NameServer listening on the host specified by the -H option and on the port specified by the -S option (5162 by default) given in the connection string of the CONNECT() method.

If there is no NameServer listening on that host/port combination, the following occurs:
- On Windows platforms such as Windows 2000, the TCP/IP layer immediately understands that communication with the NameServer is impossible.
- Conversely, on Windows 98 the TCP/IP layer tries to connect to the NameServer 5 times before giving up. The retransmission timeout is initially 3 seconds, which is then doubled to 6, 12 etc.; the 5 retries may add up to some 100 seconds or even longer.

Because Progress relies entirely on the TCP/IP stack for communication with the NameServer, the consequence is that on Windows 98 the CONNECT() method may take very long before it times out.

FIX:

This is a Microsoft Windows 98 issue. Please contact Microsoft for further assistance.