Consultor Eletrônico



Kbase P14653: Error 10894 when accessing an OpenEdge Web Service
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/14/2009
Status: Verified

SYMPTOM(s):

Error 10894 when accessing an OpenEdge Web Service

An error was detected in the Web Service request. (10894)

The WSA log file with logging level 4 (extended) shows errors 10921 and 10908.

The <URN> service is unavailable (10921)

The client was not authorized to perform the operation. (10908)

The error occurs when calling a Web Service operation

The Java Servlet Engine (JSE) returns WSA OK 101 when accessing the WSA URL in a web browser

Can access WSDL from web browser

Using State-Free AppServer

Using Document/Literal as the WSDL Style/Use

AppServer log did not reflect the request

FACT(s) (Environment):

OpenEdge 10.x
All Supported Operating Systems

CAUSE:

The WSA instance (e.g. wsa1) is disabled by default (value of webAppEnabled=0 in ubroker.properties).

FIX:

Please enable the WSA instance inside the Progress Explorer by going into the properties of WSA instance (e.g. wsa1) and selecting "Enable Web Services" under the Security section. You can also do this by adding 'webAppEnabled=1' under the WSA instance section (e.g. [WSA.wsa1]) of the ubroker.properties file.