Consultor Eletrônico



Kbase P14652: Incorrect Display sizes caused by lack of FONT Registry Keys
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   04/03/2009
Status: Verified

SYMPTOM(s):

Incorrect Display sizes caused by lack of FONT Registry Keys

Some users get errors within specific windows of application.

FACT(s) (Environment):

Custom installation for application modifies FONT entries in registry.
Progress 8.2x
Progress 8.3x
Progress 9.x
OpenEdge 10.x
Some users on same machine get no errors within specific windows of appllication.
Windows

CAUSE:

Registry Keys for Fonts don't exist or permissions to use Registry Keys for Fonts are insufficient.

FIX:

If you are making changes to the FONTS section of the Progress Registry key it may be prudent to modify not only the entries under HKEY_CURRENT_USER\Software\PSC but also under HKEY_LOCAL_MACHINE\Software\PSC since HKEY_CURRENT_USER is valid only for a specific login.

It may also be necessary to verify with regedt32.exe that all users who need to use Progress have rights to touch the HKEY_LOCAL_MACHINE registry keys.

The default order of precedence Progress uses when starting up to get its basic configuration data for the client is to:
1) Look into the Icon Properties to see if there is a reference -basekey INI
which is an override parameter telling the Progress client not to use the registry.
2) If there is no mention of the -basekey INI parameter in the startup command/icon then look in the registry in the key HKEY_CURRENT_USER\Software\PSC\<progress version>
3) If there is a permission problem reading the key listed above or if the key isn't there then look in the registry in the key
HKEY_LOCAL_MACHINE\Software\PSC\<progress version>