Consultor Eletrônico



Kbase P14068: 'File in use' error occurs when installing a Service Pack
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/30/2008
Status: Verified

SYMPTOM(s):

'File in use' error occurs when installing a Service Pack.

The files in use include: image.dll, msg.dll, util.dll and _isdel.exe, img.exe, msgexe, util.exe.

Installation message: Shutdown these running processes before reinstalling

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x
Windows

CAUSE:

The service pack installation was attempted from a directory that was created under the current Progress product installation directory, i.e. a Subdirectory of the DLC.

For example:
The Progress install directory (%DLC%) is d:\progress
Service pack was unzipped to d:\progress\Updates


FIX:

To resolve this problem, follow these steps:

1. Move the newly created subdirectory to a new location (somewhere other than under the current Progress product installation directory). Then check that there are no read-only flags on all directories of the unzipped Service Pack.
example: d:\Updates

2. Ensure that all Progress Services and executables are shut down.

3. *** Set the Adminservice to MANUAL startup ***

4. Reboot the machine. (optional)

5. Run the Progress service pack installation routine from the new location with a Local Admin privileged account.
setup.exe