Consultor Eletrônico



Kbase P14067: Error 8431 when validating the ubroker.properties file via asconfig
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/10/2008
Status: Verified

FACT(s) (Environment):

Progress 9.1x

SYMPTOM(s):

Error running the asconfig command

Cannot find for type . (8431)

Cannot find for type AS. (8431)

The AppServer referenced in error 8431 does exist in the ubroker.properties file

CAUSE:

The ubroker.properties file is corrupted, possible as a result of manually editing the file

FIX:

Follow the steps bellow:
1) Log in with Administrator privileges on Windows, or as root on Unix
2) Go to the directory where your ubroker.properties is (usually it in in the properties subdirectory of the Progress installation directory)
3) Make a copy of ubroker.properties to be on the safe side
4) Shutdown any other service running that uses this configuration file
5) Open ubroker.properties in your favorite editor and search for string '%%' (no quotes).
You'll find something similar to:
%% Properties file converted to version 9.1d
%% version 9.1d
%% Nov 19, 2002 3:34:25 PM

Be aware that you might not find all these 3 lines; that would be a clear symptom of file corruption

6) Remove the lines found on step 5
7) Save the file and exit the file editor
8) From the OS prompt run:

ubconfig -f <full path>/ubroker.properties

You will see the following messages:

Converting properties file <full path>/ubroker.properties to version 9.1d...
End Property file conversion.
The ubroker.properties file is now correct.

Running asconfig will work.