Consultor Eletrônico



Kbase P14040: ** Could not connect to server for database , errno . (1432)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   06/07/2009
Status: Verified

SYMPTOM(s):

** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)

** Could not connect to server for database <DATABASE>, errno 238. (1432)

Client on HPUX receives 1432 error with OS comment 238

FACT(s) (Environment):

All Supported Operating Systems
Progress/OpenEdge Product Family

CAUSE:

Ports used on client do not match ports used on server to startup database.

FIX:

Error 238 on HPUX is connection timeout
# define ETIMEDOUT 238 /* Connection timed out */

Review database startup parameters to confirm the client and server values for
-N <value> -S <value> and -H <value> match.

Review the services files of the client and server machines.
Verify that the ports
ames used for the -S parameter have been entered in the services files and that the ports match
(the names don't need to match if the ports they name are aliased to match.)
To verify what port the database is using use promon
promon <DBNAME>
R&D
1
3
The ports the data is using to listen on are listed with lines that have a type of LOGIN. There may be several of these lines for the
primary and any secondary Brokers which are configured.
Look to see if the port, which was originally planned for use by this database, is in fact the port being used.

After the database port has been confirmed verify that the port specified by the client is the same.

When using service names instead of port numbers review the services file on the system to verify that the service name is associated
with the correct port number on client and server machines.