Consultor Eletrônico



Kbase P13998: Can't attach to Shared Memory error at start up due to existing .lk file
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   04/06/2009
Status: Verified

SYMPTOM(s):

.lk file present in database directory

Database fails to start.

There is no server for database <>. (1423).

System Error: Can't attach Shared Memory with segment_id: <> for <>

FACT(s) (Environment):

All Supported Operating Systems
Progress 7.x
Progress 8.x
Progress 9.x
OpenEdge 10.x

CAUSE:

Database was not shut down before Server was rebooted.

FIX:

Perform the following:
1) Check that there are no processes using the DB files.
2) If no processes are accessing the database files, then remove .lk file.
3) Restart the database