Kbase P13988: How to investigate shared memory version errors 1178 and 1423
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  13/11/2008 |
|
Status: Verified
SYMPTOM(s):
Connecting to database through shared memory
Connecting to the database single-user
The shared memory is version <num>; expected <num> (1178)
There is no server for database <dbname>. (1423)
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Product Family
CAUSE:
Applied a Progress service pack to the Progress installation to a location other than where Progress is installed on the machine.
FIX:
Progress recommends that both client and server products on the same physical machine, should be running consistent patch levels Progress because our development may change the shared memory version of Progress within a patch for diagnostic reasons.
STEPS:
1. Set the PROEXE environment variable to point to the the patched _progres/prowin32.exe executable.
2. Set the PROSRV to the patched version of the server executable (_mprosrv).