Kbase P13832: Firewall timeout problems causes WebSpeed errors
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/8/2003 |
|
Status: Verified
FACT(s) (Environment):
Progress 3.1x
SYMPTOM(s):
Webspeed brokers shut down with error 8419 in broker logs
Unhandled exception caught in <threadName>. (8419)
Errors 6019 and 5814 displayed in browser when brokers go down
Webspeed error from messenger process (6019)
Msngr Disconnected with no header on WTA output web stream (5814)
Error 778 in server log files
Error reading socket, ret=0, errno=2.(778)
All the webspeed brokers came down at the same time
Webspeed running on Unixware
Database running on SCO Open Server
Database was up when the errors 6019, 5814 and 778 occurred
Firewall exists in between the database and webspeed transaction server
Connection timed out on socket=<n> for usernum <n>, attempt disconnect. (1280)
Error 1280 displayed in database log file
CAUSE:
The firewall between the WebSpeed server and the database server times out the connection due to lack of activity.
FIX:
Set the TCP keepalive idle period on the database and WebSpeed servers to be less than the firewall timeout period.
The connection will timeout on the TCP keepalive which will cause TCP to send keepalive packets to verify that the connection is still live.
Provided the connection is still open, the TCP keepalive idle timer will be reset and the passage of the keepalive packets will stop the firewall idle timer from timing out.
The default idle time on this firewall was 60 minutes, so set the TCP idle time is set to 50 minutes.
Method:
Adjust following files
SCO Openserver.
/etc/default/inet
SCO UnixWare 7
/etc/inet/inet.dfl