Kbase P12860: Error unmarshalling return when connecting to AdminServer after installing Fathom
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1C
Progress 9.1D
Fathom 2.0A
SYMPTOM(s):
Errors connecting from a remote client's Progress Explorer session to AdminService.
Fathom installed on the server
Fathom is not installed on the client
unmarshalling java expection when connecting to AdminServer
error unmarshalling return; nested exception is: java.lang.ClassNotFoundException
Connection failed. Server is not available. (7447)
Lost connection to Admin Server on . Please verify it is running. (9172)
CAUSE:
Fathom.jar file is missing from the client machine's Progress install.
FIX:
Follow these steps to get Progress Explorer connecting to the AdminServer:
Copy the fathom.jar file from an existing Fathom install (It can be found in $FATHOM/jars subdirectory) to any directory on client machine
Go into the registry and edit the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\version\JAVA\FATHOMCP
Modify this key to point to the fathom.jar.
After this Progress Explorer should now connect to the system where Fathom is installed. It may be necessary to stop and restart the Progress AdminService.
This information may be found in the Release Notes for Fathom 2.0A.